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1 Features

LinLogBook is a highly configurable logbook program. It uses sqlite as sql -
database to store its data.
You can export your qso data to a file in adif format for uploading to eqsl or
you can directly label your qsl cards.
You can configure LinLogBook by defining some tables and assigning some val-
ues during the setup process. For more infomations see section 5.
LinLogBook supports two modes

• Enter the qso data manually

• Run LinLogBook as TCP Logbook server

You can import and export the data in adif format.

2 Requirements

LinLogBook was tested with gcc 4.1.2 and uses sqlite as sql- database version
3.x. It requires qt 4.3 or higher.

3 Installation

LinLogBook uses qmake, so the process of building does not use the autoconf
tools.
Do the following steps:

• Untar the LinLogBook package
tar xzf LinLog-0.1.2.tar.gz

• Switch to the LinLog directory

• run:
qmake -unix -o Makefile linlog.pro
make

• linlog is build in the bin subdirectory. Move the binary into prefered
location , probably /usr/local/bin

• It is recommended that you create a working directory for LinLogBook.
For instance create .LinLog in your homedirectory and copy the file BaseTables.sql
into this working directory.

Now you can start linlog and choose your personal setup.

4 For the impatient

After the installation start LinLogBook and run linlog.
Select File : new Database and select a name for your database.
Select Edit : Create Basetables
Select the file Example.sql from the LinLog directory.
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Select Edit : Define Database Fields and modify the Column LinLogFields and
the column DefaultValue depending on your needs and click OK.
Then select Edit : Create QSo tables
Now your are ready to retrieve qso data.

5 Configuration

Start LinLogBook and go to Edit menu. Select Preferences and fill out the
form. The directory entry is relative to your home directory. It is a good idea
to choose the same directory where you have put BaseTable.sql.
Select the File menu and create a new database. Then change to the Edit menu
and create the basetables. You can use the file BaseTables.sql distributed with
LinLogBook or you can adjust the tables to your needs by modifying the file
BaseTables.sql.
The table ADIF contains the possible entries your logbook could contain. This
table consists of the columns ADIFName and Type. The ADIFNames are
taken from the ADIF 2 specifications.( http://www.adif.org/adif218.htm ). You
should only use valid adif names, as these names are taken for exporting the
data. I put some names into the table that I use within my own logbook. But
there are much more possible entries.
LinLogBook uses the following types of the adif specification:

• String labeled S

• Date labeled D ( You can choose the preferred date format in the Prefer-
ences panel )

• Time (HH:MM) labeled T

• Gridsquare labeled G . This labeling is used to be able to check the formal
syntax of the entered values. If exported in adif format it is outputed as
string.

• Enumeration labeled E. For each enumeration you must setup an extra
table. See section 6

• Number labeled N. At the moment treated as string.

• Multiline string labeled as M. At the moment treated as string.

After the definition of the basetables you can choose the items you wish to use
in your logbook.
To do so, select Define Database Fields in the Edit menu and you’ll get the
following form:
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Select the entries you want to use and move them into the right box. Insert
an descriptive text in the third column of the right box. This text will be used
as an column header in your logbook later on. The columns appear in your
logbook in the same order as the appear in the right box. If you want to change
the order of your columns , use the up and down arrows beneath the right box.
You can change the columns and their order as long as you didn’t create the
qso table.
You can assign default values to the fields of type ’E’ and the type ’N’. You do
this by double clicking corresponding field of the column labeled DefaultValue.
If you are satisfied with your definitions create the qso table. Again you find
this topic in the Edit menu.
Now your logbook is ready to use.

6 Tables for enumerations

For each entry of type enumeration a table containing the posible values must
be created. The name of this table must be the name of entry. This table
contains two columns. The first is named Id and the second the name of the
table followed by value.
The following example is taken from the definition of the enumeration of the
band entry:

create table BAND (Id INTEGER PRIMARY KEY AUTOINCREMENT,
BANDvalue UNIQUE NOT NULL);
insert into BAND (BANDvalue) values(’160m’);
insert into BAND (BANDvalue) values(’80m’);
insert into BAND (BANDvalue) values(’60m’);
insert into BAND (BANDvalue) values(’40m’);
insert into BAND (BANDvalue) values(’30m’);
insert into BAND (BANDvalue) values(’20m’);
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insert into BAND (BANDvalue) values(’17m’);
insert into BAND (BANDvalue) values(’15m’);
insert into BAND (BANDvalue) values(’12m’);
insert into BAND (BANDvalue) values(’10m’);
insert into BAND (BANDvalue) values(’6m’);
insert into BAND (BANDvalue) values(’2m’);
insert into BAND (BANDvalue) values(’70cm’);

If you ’ll work other bands, too, you can enter these bands into this table.
Otherwise, if you never operate in some of these bands, you can remove these
entries. In this way you can configure LinLogBook depending on your needs.

7 Usage

Start LinLogBook. Open your database from the File menu. Now you can enter
your qso data. To make the logging easier, you can select default values for the
band and the mode.
You can search in your loogbook for a qso with a special callsign by entering the
callsign in the callsign field. If you enter only some initial values all callsigns
starting with these values are looked for and the qsos are listed.

7.1 File Menu

Open Database

Here you open an existing database for further processing.

New Database

Here you create a new database. If you select the name of an existing one its
contents will be overwritten.

Save Database Definition

You can save the definitions ( sql statements ) of your logbook as a file.You can
use this file to setup a new logbook by executing this file in
Edit ⇒ Create basetables .
Hint If you want to modify your logbook, for instance inserting some new
columns, save your definitions and export all your qso data as an adif file.
Then setup a new, empty database. Use your stored definitions as basetables.
Afterwards you can modify your column setup. After creating the new qso table
you can restore your qso data be importig the saved adif file. Don’t forget to
save the views, too.

Save Views

If you have created views - for instance to calculate some statistics - you can
save your views to a file, for later use.
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Import cty.dat

The cty.dat file contains DXCC entities and is maintained by Jim Reisert, AD1C.
See http://country-files.com for more information and download
To import the city.dat file just download it and then run Import cty.dat from
the File menu

Import Adif File

You can import adif data from a file into your logbook. Adif fields in your file
that are not defined in your logbook will be ignored.

Export Adif File

You can export all of your logged data into one file. So you can save your data.

Export for EQSL upload

If the ADIF field QSL SENT is used all records having QSL SENT set to ’R’
will be exported to a file. This file could be uploaded to eqsl.cc for instance.
While exporting these data the status of the field QSL SENT is set to yes and
if the field QSL SENT VIA was added to your database fields it will be set to
’e’.

Print QSL Card

If the ADIF field QSL SENT is used all records having QSL SENT set to ’Q’
will be printed. You can choose as destination either a printer or a file. Printing
to file generates a pdf document. You must define the layout of the print output
in the QSL Card Setup in the Edit menu. You will be asked if the print was
ok. If you say yes, QSL SENT is set to yes, otherwise the QSL SENT remains
unchanged.

7.2 Edit Menu

Here you find the main tasks to configure the appearence and the characteristics
of your personal logbook.

Create Baseteables

If you setup a new logbook first you have to define which elements the logbook
should possibly contain. This is done by creating the basetables. LinlogBook
contains a file BaseTables.sql that contains a set of usefull definitions. These
definitions are made by sql statements and you can expand them by editing this
file. For example you can add adif fields by adding values to the ADIF table.
You can also expand or reduce the list of bands and modes you are working by
editing this file.
You can create these basetables only once
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Define Database Fields

By defining the database fields you select those fields you will actually use in
your logbook and you label the columns. You can change this selection up to
the final creating of the qso table.

Create QSO Table

Creating the qso table means establishing the logbook. LinLogbook is ready for
use. After this step you can’t change the defintion of this logbook anymore.

Update Basetables

Here you can execute sql statements stored in a file.
Two possible usecases are

• You want to expand the bands or modes that can be assigned in your
logbook. Write the insert statements into a file and choose this file to
update your basetables. In the file BaseTables.sql you see the syntax of
the appropriate sql statements.

• If you want to expand the features of your logbook by inserting additional
columns you did not use up to now, you have to recreate your logbook.
First you have to save the database definitions and views to files and store
the entered data into another file by exporting them as adif file.
Then you can create a new database and load your previous definitions by
updating the ( at this moment empty ) basetables by the stored database
definitions.
After this step the qso table is not defined yet, so you can expand your
definition by new database fields. If the favoured fields are not in the adif
field list, you have to update your ADIF table. For more infomations see
section 5. If the definition fits your needs, create the qso table and create
the views ( if necessary ) by updating the basetables by running the file
you saved your views to.
Now import your saved adif data and your redesigned logbook is ready for
use.

QSL Card Setup

Here you define which fields of your logbook will be printed to your qsl card.
Additionally you have to define the print position in mm and you can choose a
font size between 8 and 12 points.
You are even able to print some text conditionally. I use this to mark either the
TNX QSL or the PSE QSL text on my qsl card.
Here is my setup. Have a look at the two entries of QSL RCVD.
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Preferences

At least the database directory, the date format and the separator should be
set. You have to set the port, if you want to be able to run the linlog server.
The language selection will not be utilised at the moment and the other fields
are for later use, too.

7.3 Statistics

LinLogBook owns a simple interface to define statistics. It uses the sql table
statistics which has the following definition:
create table statistics (MenuText UNIQUE NOT NULL,sql NOT NULL);
The first column contains the name of entry in the Statistics menu. The second
entry contains the corresponding sql statement to calculate the desired statistic.
You find two examples in the file Statistics.sql. The first example counts
the number of confirmed and unconfirmed qsos for each worked band and mode
whilst the second example counts the worked and confirmed qsos for each coun-
try. This example requires the cty.dat file to be imported.
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You implement this statistics by running Update Base Tables from the Edit
menu. Select the file Statistics.sql for this update.After restarting LinLogBook
the statistics are available.
You can implement your own statistics by updating the statistics table. Have
a look at the Statistics.sql file for some explanations.

7.4 Server Mode

Additionally you can run LinLogBook in server mode. To do so select start
server in the server menu. A small TCP- server will listen on all interfaces. The
port is configurable in Preferences in the Edit menu. This feature is intended
to be used together with programs for digital modes.
Data have to be sent in adif format on a per line basis. Each adif entry has
to be one line. Sending <eor> means end of record and leads to storing the
received data.
Sending @@@@callsign requests informations on the callsign. LinLogBook
sends back some country information and if the callsign has already been worked.

8 Apendix

8.1 Update from 0.1.1 to 0.1.2

To use the complete functions of LinLog 0.1.2 the database tables have to mod-
ified. If you are already using an earlier version of LinLog you can do this the
following way

• Install LinLog 0.1.2

• For security reasons copy your database file to a new file

• Run LinLog 0.1.2 and open your database

• Export the database contents using export Adif File in the File Menu
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• Save the database definition to an file using the corresponding item in the
File Menu

• Restart LinLog 0.1.2 and create a new database. You may use the same
name for yor database. In this case the old database will be overwritten.

• Run Create Basetables from the Edit menu
Choose the file you saved your database definitions to.

• Run Update Basetables from the Edit menu
Choose the file updateBaseTables-0.1.1-0.1.2.sql from the LinLog directory

• Run Define Database Fields from the Edit menu
Now you can choose default settings for all enumeration types ( Band,
Mode ) and numerical types ( TX POWER) by double clicking into the
DefaultValue column.
A new ADIF - field QSL SENT VIA was introduced to the database
definitions. If you add this field to the used database fields, you can keep
track of eqsl - upload.

8.2 Update to LinLogBook 0.2

To achieve a better representation of the statistics it was inevitable to slightly
modify the qsos table. To make use of this modification do the following.

• Install LinLog 0.2

• For security reasons copy your database file to a new file

• Run LinLog 0.2 and open your database

• Export the database contents using export Adif File in the File Menu

• Save the database definition to an file using the corresponding item in the
File Menu

• Restart LinLog 0.2 and create a new database. You may use the same
name for yor database. In this case the old database will be overwritten.

• Run Create Basetables from the Edit menu
Choose the file you saved your database definitions to.

• Run Define Database Fields from the Edit menu
At this stage you might change the column names or the default values
assigned to some columns.

• Run Create Qso Table from the Edit menu

• Run Import Adif File from the File menu
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8.3 Update from LinLogBook 0.2 to 0.2.1

The list of qsos will now be ordered by QSO DATE (, TIME ON or TIME OFF).
The later depends on the fields you defined in your linlogbook.Due to problems
with some features of qt, this requires to create a view.
The easiest way is to modify the file updateBaseTables-0.2-0.2.1.sql by removing
the % sign in front of the line that fits to your logbook definition. Then run
update BaseTables from the edit Menu and choose this file to run.
If you don’t so , you won’t see your qso entries when starting LinLogBook 0.2.1.
But the entries are not lost. You will see these data again as soon as you run
the update script and restarting LinLogBook.
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